Started 7 months agoFebruary 04, 2026Lasted about 3 hoursFebruary 04, 20269:53 AM12:51 PMUTC
Affected
IMAP
Operational from 9:53 AM to 12:51 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
Inbound spam is expected to increase over the next 12-16 hours while our Expert Spam Filtering system is under maintenance required by a large increase of new customers.